Cash App

Cash App is back online
Incident Report for Cash App
Resolved
A recent connection issue with our third-party service provider caused some delays across the app. We’re sorry for any inconvenience.

We’ve resolved the issue and continue to work on any remaining impact to customers. If you aren’t sure if a transaction went through, pull down on your Activity feed to refresh.

We appreciate you being a Cash App customer.
Posted Sep 19, 2023 - 00:50 PDT
Update
Most of our services are up and running, but you might continue to experience some delays. We’re coordinating with our third-party service provider to resolve the issue, and expect it will be resolved soon. We’ll continue to provide updates as we monitor the situation.
Posted Sep 18, 2023 - 18:32 PDT
Update
Most of our services are up and running, but you might continue to experience some delays. We’re coordinating with our third-party service provider to resolve the issue, and expect it will be resolved soon. We’ll continue to provide updates as we monitor the situation.
Posted Sep 18, 2023 - 18:27 PDT
Update
We’ve identified the connection issue. It was caused by a third-party service provider that has resulted in delays across Cash App. We’re coordinating with them to implement a fix to fully restore services as soon as possible. Please do not reattempt transactions at this time. Thank you for your patience.
Posted Sep 18, 2023 - 14:52 PDT
Update
We are continuing to investigate the connection issues within the app that are causing connection issues and delays with Log In, Notifications, P2P payments, etc. If you have a payment that has failed, please do not reattempt it at this time. If you are already signed into your account, we do not recommend signing out of your account.
Posted Sep 18, 2023 - 14:15 PDT
Monitoring
We are currently investigating the connection issues within the app that are causing connection issues and delays with Log In, Notifications, P2P payments, etc. If you have a payment that has failed, please do not reattempt it at this time.
Posted Sep 18, 2023 - 12:41 PDT
Update
We're aware of connection issues within the app that are causing degraded performance. If you have a payment that has failed, please do not reattempt it at this time.
Posted Sep 18, 2023 - 12:14 PDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2023 - 11:52 PDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2023 - 11:49 PDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2023 - 11:48 PDT
Investigating
We’re investigating reports of connection issues. Please do not re-attempt any pending payments. We'll update you as soon as possible.
Posted Sep 18, 2023 - 11:13 PDT
This incident affected: Send & Receive Money, Cash App Pay, Offers, Add Cash, Cash Out, Borrow, Bitcoin, Support, In-App Alert, and Cash App Taxes.