Cash App

Intermittent Connection Issues
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 14:44 PDT
Investigating
We're experiencing connection issues and are currently investigating. If your payment is pending, please do not re-attempt at this time, it will be sent automatically.

We'll be back with an update soon - thank you for your patience.
Posted Sep 18, 2020 - 14:16 PDT
This incident affected: Send & Receive Money.