Cash App

Issues with Trading

Incident Report for Cash App

Resolved

An issue causing disruptions with Cash App Investing has been resolved. Thank you all for your patience
Posted Nov 07, 2019 - 07:12 PST

Investigating

The Cash App Investing team is investigating an issue with the trading feature right now. Please check back here for updates. Thank you for your patience.
Posted Nov 07, 2019 - 06:39 PST
This incident affected: Investing.