Cash App

Delayed P2P Payments
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 13:46 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2021 - 12:05 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 11:18 PDT
Investigating
We are currently investigating this issue.
Posted Mar 25, 2021 - 11:17 PDT
This incident affected: Send & Receive Money.