Cash App
Bitcoin Issues
Incident Report for
Cash App
Resolved
We've resolved the outage impacting bitcoin withdrawals. You may re-attempt any failed withdrawals at this time. Thank you for your patience.
Posted
Nov
08
,
2024
-
09:33
PST
Investigating
We're investigating reports of an outage impacting bitcoin withdrawals and will share another update soon. Thanks for your patience in the meantime.
Posted
Nov
08
,
2024
-
09:24
PST
This incident affected: Bitcoin and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
Bitcoin Issues
via . You'll receive .