Cash App

Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved. To check the status of your payment, please view your transaction activity. If your payment is still pending, please pull down on the screen to refresh and send.

Thanks again for your patience as we worked to resolve this issue.
Posted Jun 02, 2021 - 01:02 UTC
Update
Our team has identified the issue causing pending payments, and we are continuing to work on a resolution. As a reminder, there is no need to retry any pending payments at this time. We'll return with another update as soon as possible.
Posted Jun 02, 2021 - 00:29 UTC
Identified
We've identified the root cause, and making progress on any backlogged payments. If your payment is pending, it should be sent shortly. Please do not reattempt a pending payment at this time. We'll be back with an update once everything is fixed.
Posted Jun 01, 2021 - 21:11 UTC
Update
Our team is continuing to investigate the connection issues causing pending payments, and we will be sharing updates here as we learn more.
Any affected payments should process automatically, so if you have a payment that's pending, please do not reattempt it at this time.
Posted Jun 01, 2021 - 20:41 UTC
Update
We are continuing to investigate this issue.
Posted Jun 01, 2021 - 20:35 UTC
Investigating
We're experiencing some connection issues and are investigating. If your payment is pending, please do not re-attempt at this time.

We'll be back with an update shortly.
Posted Jun 01, 2021 - 20:26 UTC
This incident affected: Send & Receive Money and In-App Alert.