Cash App

Cash Card Transactions
Incident Report for Cash App
Resolved
We had a brief issue causing incorrect notifications being sent regarding transactions, but our team has since resolved this issue.
Posted Sep 30, 2021 - 12:23 PDT
Investigating
We're aware of an issue showing "insufficient balance" on unrecognized transactions showing in-app and are actively investigating.

We'll return with an update as soon as we have more information - thank you for your patience.
Posted Sep 30, 2021 - 11:21 PDT
This incident affected: Cash App Card.