The issue with Cash App Investing orders experiencing intermittent delays has been resolved. If your order has not been completed or was cancelled, you may reattempt to place it at this time. Thank you for your patience as we worked to resolve this matter.
Posted Feb 07, 2025 - 13:07 PST
Update
We are continuing to investigate this issue.
Posted Feb 07, 2025 - 13:06 PST
Update
We’re currently looking into an issue with Cash App Investing. Please check back here for updates.
Posted Feb 07, 2025 - 08:55 PST
Investigating
We’re currently looking into an issue with Cash App Investing. Please check back here for updates.
Posted Feb 07, 2025 - 08:36 PST
This incident affected: Investing and In-App Alert.