Cash App

Notification Delay
Incident Report for Cash App
Resolved
Our team has a fix in place for anyone encountering delayed notifications, and anything that was delayed should have arrived by now.
Posted Apr 24, 2021 - 15:16 UTC
Investigating
We're investigating an issue causing notifications to take a little longer than normal. We'll share updates here, but you should see your notification arrive shortly.
Posted Apr 23, 2021 - 20:34 UTC
This incident affected: Settings.