Cash App

Test - Cash App Cards - Investigating

Incident Report for Cash App

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 13:56 PST

Update

We are continuing to investigate this issue.
Posted Mar 06, 2026 - 13:55 PST

Investigating

We’re investigating reports of connection issues impacting multiple Cash App features, and are working to resolve this quickly. Thanks for your patience in the meantime.
Posted Mar 06, 2026 - 13:55 PST
This incident affected: Cash App Card, Cash App Pay, and In-App Alert.