Cash App

Intermittent Connection Issues
Incident Report for Cash App
Resolved
This issue has been resolved - thanks for your patience.
Posted Mar 24, 2020 - 16:04 UTC
Investigating
Some customers may currently be experiencing connection issues including issues with Cash App Investing. Some orders may be delayed. Please check back here for updates.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted Mar 24, 2020 - 15:54 UTC
This incident affected: Investing and Settings.