Cash App

Cash App Connection Issues

Incident Report for Cash App

Resolved

We've resolved the outage affecting multiple Cash App features. Thank you for your patience.
Posted Apr 25, 2025 - 11:27 PDT

Investigating

We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience, we'll provide an update soon.
Posted Apr 25, 2025 - 11:14 PDT
This incident affected: Send & Receive Money, Cash App Pay, Add Cash, Cash Out, and In-App Alert.