Cash App

Connection Issues

Incident Report for Cash App

Resolved

We've resolved the issue impacting payments. You may re-attempt any failed transactions at this time, any payments that were pending should be completed. Thank you for your patience.
Posted Sep 02, 2025 - 06:57 PDT

Identified

We're aware of connection issues which are impacting payments. Thanks for your patience while we look into this. Please do not retry any payments in the meantime.
Posted Sep 02, 2025 - 06:25 PDT
This incident affected: Send & Receive Money and In-App Alert.