Cash App

Unable to Cash Out
Incident Report for Cash App
Resolved
The issue in regard to Cash Out's have been fixed. Feel free to retry to Cash Out once funds are returned back to your balance.
Posted Nov 11, 2023 - 10:08 PST
Investigating
We're aware of the issues in regard to Cash Outs being stuck. Please do not retry cashing out at this time. For updates, please visit status.cash.app (https://status.cash.app/)
Posted Nov 11, 2023 - 08:53 PST
This incident affected: Cash Out.