Cash App

In-app Verification
Incident Report for Cash App
Resolved
A fix has been implemented and we're currently monitoring results. We'll return with another update soon.
Posted Nov 20, 2020 - 01:50 UTC
Investigating
We're experiencing an issue with uploading documents in-app for verification and are investigating. We'll be back with an update soon - thank you for your patience.
Posted Nov 20, 2020 - 01:04 UTC