Cash App

Delayed Payments for UK Customers
Incident Report for Cash App
Resolved
The issue with delayed payments for UK customers has been resolved. Thank you for your patience.
Posted 7 days ago. Aug 11, 2019 - 06:30 UTC
Identified
We have identified the cause of delayed payments for some UK customers and are working to resolve. Thank you for your patience.
Posted 8 days ago. Aug 11, 2019 - 04:14 UTC
Investigating
We're investigating reports of delayed payments for some UK customers and are working quickly on a solution. Thank you for your patience.
Posted 8 days ago. Aug 11, 2019 - 03:58 UTC
This incident affected: Send & Receive Money.