We've resolved the issue affecting Cash App Taxes. You can find support for general tax-related questions at taxeshelp.cash.app. We appreciate your patience while we worked to resolve this matter.
Posted Jun 12, 2025 - 13:48 PDT
Update
We're investigating reports of an issue impacting Cash App Taxes. Thanks for your patience while we look into this.
Posted Jun 12, 2025 - 11:43 PDT
Investigating
We're investigating reports of an issue impacting Cash App Taxes. Thanks for your patience while we look into this.
Posted Jun 12, 2025 - 11:30 PDT
This incident affected: In-App Alert and Cash App Taxes.