Cash App

Temporary Outage for Cash App Taxes 9/3/24 @8am EST
Incident Report for Cash App
Resolved
We've completed the scheduled maintenance for Cash App Taxes. You can find support for general tax-related questions at taxeshelp.cash.app. Thanks for your patience.
Posted Sep 03, 2024 - 07:23 PDT
Identified
We are currently performing scheduled backend updates to enhance our services, which will temporarily impact your ability to access Cash App Taxes and our ability to provide support. For approximately 1-2 hours on 9/3/24, Cash App Taxes and Cash App Taxes support will be unavailable.

We understand this may be inconvenient and appreciate your patience during this maintenance period. If you need immediate assistance or have questions about your account, please reach out to our support team once the update is complete, and we will be happy to assist you.

Thank you for your understanding.
Posted Sep 03, 2024 - 05:19 PDT
This incident affected: In-App Alert and Cash App Taxes.