Cash App

Balance Confusion
Incident Report for Cash App
Resolved
This incident has been resolved. We appreciate your patience.
Posted Nov 07, 2020 - 15:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 05, 2020 - 18:49 UTC
Investigating
We are currently investigating an issue causing your in-app balance to not update after sending/receiving a payment, Adding Cash or completing a Cash Card transaction. This issue isn't impacting those features, just the balance. We'll have an update soon.
Posted Nov 05, 2020 - 16:49 UTC