Cash App

Cash Card - Apple Pay Transactions
Incident Report for Cash App
Resolved
All duplicate Cash Card transactions with Apple Pay have been refunded. If you've been affected by this issue your duplicate charge will show as a separate refund in your transaction activity.
Posted Nov 22, 2019 - 17:19 PST
Monitoring
We've implemented a fix, and any duplicate Cash Card transactions made as a result of this issue will be automatically refunded shortly. We'll be back with a final update once all duplicate transactions have been refunded. Thank you for your patience this afternoon.
Posted Nov 22, 2019 - 15:45 PST
Investigating
We're aware of an issue causing some customers to experience duplicate Cash Card transactions when paying with Apple Pay and are currently investigating. Please do not retry your purchase using Apple Pay at this time. Payments made using your physical Cash Card will complete as expected. We'll return with an update as new information becomes available.
Posted Nov 22, 2019 - 14:36 PST
This incident affected: Cash App Card.