Cash App

Cash App Taxes Support Issues
Incident Report for Cash App
Resolved
We've resolved the issue affecting your ability to contact Cash App Taxes Support. You can now find support for general tax-related questions at taxeshelp.cash.app. We appreciate your patience while we worked to resolve this matter.
Posted Dec 03, 2024 - 09:02 PST
Investigating
We are aware of an issue affecting your ability to contact Cash App Taxes Support and are actively investigating a solution. We appreciate your patience as we work to resolve this matter.
Posted Dec 03, 2024 - 08:17 PST
This incident affected: In-App Alert and Cash App Taxes.