Cash App

Cash App Taxes Outage
Incident Report for Cash App
Resolved
We've resolved the planned outage to our Cash App Taxes platform. You can find support for general tax-related questions at taxeshelp.cash.app. Thanks for your patience.
Posted Oct 21, 2024 - 11:26 PDT
Monitoring
Cash App Taxes is currently in the process of transitioning our systems in preparation for the 2024 tax year. During this time, our services will be temporarily unavailable, but we expect to be back online shortly. We apologize for any inconvenience this may cause and appreciate your patience as we work to ensure a seamless experience for the upcoming tax season. Thank you for your understanding, and we look forward to serving you soon.
Posted Oct 21, 2024 - 07:55 PDT
This incident affected: In-App Alert and Cash App Taxes.