Cash App

Delay in Stock Market Prices
Incident Report for Cash App
Resolved
The issues with Cash App Investing has been resolved - thank you for your patience.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 03, 2021 - 09:58 PDT
Monitoring
A fix has been implemented and we're currently monitoring results. We'll return with another update once this issue has been fully resolved.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 03, 2021 - 09:54 PDT
Update
We’re currently looking into an issue with Cash App Investing. Please check back here for updates.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 03, 2021 - 09:47 PDT
Investigating
We are currently investigating this issue.
Posted May 03, 2021 - 09:43 PDT
This incident affected: Investing.