Cash App

Bitcoin Balance Updates Delayed
Incident Report for Cash App
Resolved
The issue causing delayed Bitcoin balance updates after buying or selling has been resolved. All balances are now up-to-date. Thank you for your patience.
Posted May 21, 2020 - 22:39 UTC
Investigating
Some customers may be experiencing delayed updates to their in-app balance after buying or selling Bitcoin - we're currently investigating.

We'll return with an update shortly.
Posted May 21, 2020 - 19:53 UTC
This incident affected: Bitcoin.