Cash App
Cash App Connection Issues
Incident Report for
Cash App
Resolved
We've resolved the outage affecting multiple Cash App features. Thank you for your patience.
Posted
Aug
31
,
2024
-
07:11
PDT
Update
We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience, we'll provide an update soon.
Posted
Aug
31
,
2024
-
06:54
PDT
Investigating
We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience, we'll provide an update soon.
Posted
Aug
31
,
2024
-
06:38
PDT
This incident affected: Send & Receive Money, Cash App Card, Cash App Pay, Add Cash, Cash Out, Bitcoin, In-App Alert, and Log In.
×
Subscribe to Incident
Subscribe to updates for
Cash App Connection Issues
via . You'll receive .