Cash App

Cash Card Double Authorizations
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted 16 days ago. Sep 28, 2019 - 13:51 UTC
Monitoring
A fix for the issue causing duplicate Cash Card authorizations has been deployed. We’re working to rectify any outstanding duplicate charges, and your balance will reflect the correct amount soon if it doesn't already. We’ll be back with a final update once all duplicate transactions have been corrected. Thank you for your ongoing patience.
Posted 17 days ago. Sep 28, 2019 - 00:08 UTC
Investigating
We’re currently investigating reports of duplicate Cash Card authorizations on transactions made using Apple Pay. These authorizations will be corrected as soon as we’ve resolved the issue. We’ll return with an update as new information becomes available.
Posted 17 days ago. Sep 27, 2019 - 18:06 UTC
This incident affected: Cash Card.