Cash App
Cash App Card Issue
Incident Report for
Cash App
Resolved
We've resolved the issue impacting Cash App Card transactions to blocked merchants. Thank you for your patience while we worked through this.
Posted
Jan
10
,
2025
-
15:58
PST
Update
We are continuing to investigate this issue.
Posted
Jan
10
,
2025
-
15:57
PST
Investigating
We're investigating an issue impacting Cash App Card transactions to blocked merchants. Thanks for your patience while we work to resolve this.
Posted
Jan
10
,
2025
-
12:29
PST
This incident affected: Cash App Card and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
Cash App Card Issue
via . You'll receive .