Cash App

Service Disruption

Incident Report for Cash App

Resolved

The previous issue with Mastercard payment processing now resolved. We appreciate your patience throughout this resolution process.
Posted Aug 14, 2026 - 22:55 PDT

Investigating

We are currently experiencing intermittent disruptions with Mastercard payment processing. As a workaround, we recommend customers use a non-Mastercard form of payment if available.

Thanks for your patience in the meantime.
Posted Aug 14, 2026 - 21:44 PDT
This incident affected: Send & Receive Money.