Cash App

Identity Verification Issues

Incident Report for Cash App

Resolved

We have resolved the issue impacting some customer's ability to verify their identity. Thanks for your patience while we worked through this.
Posted Jun 12, 2025 - 14:13 PDT

Investigating

We are looking into an issue impacting customers ability to verify their identity. Our team is working hard to investigate, thanks for your patience in the meantime.
Posted Jun 12, 2025 - 11:53 PDT
This incident affected: In-App Alert.