Cash App

Connection Issues

Incident Report for Cash App

Resolved

We've successfully resolved the issue that was preventing customers from filing disputes. All dispute filing functionality has been restored and is operating normally. Customers can now proceed with filing disputes through the standard process. We appreciate everyone's patience while we worked to resolve this matter.
Posted Sep 10, 2025 - 12:17 PDT

Identified

We've identified the issue impacting customers ability to file disputes, we will share another update soon. Thanks for your patience in the meantime.
Posted Sep 10, 2025 - 11:48 PDT

Investigating

We're investigating reports of an issue impacting customers ability to file disputes, we will share another update soon. Thanks for your patience in the meantime.
Posted Sep 10, 2025 - 10:54 PDT
This incident affected: Send & Receive Money, Cash App Card, and In-App Alert.