Cash App

Login Issues
Incident Report for Cash App
Resolved
Our team has resolved today's login issue. Thank you for bearing with us.
Posted Jul 21, 2021 - 22:54 UTC
Investigating
We're aware of some customers having issues logging into the app. We're investigating and will continue to share updates.
Posted Jul 21, 2021 - 22:39 UTC
This incident affected: Settings.