Cash App

Paid Cash Card Issues
Incident Report for Cash App
Resolved
We've resolved the issue preventing Android customers from purchasing Cash Cards. You are now welcome to complete your purchase at this time.
Posted Jun 03, 2021 - 17:31 PDT
Investigating
We’re aware of an issue affecting Android customers and their ability to order paid Cash Cards, and will share updates here.
Posted Jun 03, 2021 - 14:08 PDT
This incident affected: Cash App Card.