Cash App

Delayed Payments and Login Issues
Incident Report for Cash App
Resolved
Today's connection issues with payments and notifications have been fully resolved. To check the status of your payment, please view your transaction activity. If your payment is still pending, please pull down on the screen to refresh and send.

Thanks again for your patience as we worked to resolve this issue.
Posted Nov 21, 2020 - 19:06 UTC
Investigating
We are currently investigating some payment delays and login issues. Our team is hard at work looking for a solution. We appreciate your patience.
Posted Nov 21, 2020 - 16:21 UTC
This incident affected: Send & Receive Money and Settings.