Cash App
Support Issues
Incident Report for
Cash App
Resolved
We've resolved the issue impacting our Cash App support teams. Thanks for your patience while we looked into this.
Posted
Jun
12
,
2025
-
13:29
PDT
Update
We are investigating an issue impacting our Cash App support teams. Thanks for your patience while we look into this.
Posted
Jun
12
,
2025
-
12:20
PDT
Investigating
We are investigating an issue impacting our Cash App support teams. Thanks for your patience while we look into this.
Posted
Jun
12
,
2025
-
11:23
PDT
This incident affected: Support and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
Support Issues
via . You'll receive .