We experienced a connection issue that impacted some Cash App services. Please feel free to retry any failed attempts. We appreciate your patience while we looked into this.
Posted Apr 30, 2025 - 17:28 PDT
Identified
We experienced a connection issue that impacted some Cash App services. Please feel free to retry any failed attempts. We appreciate your patience while we looked into this.
Posted Apr 30, 2025 - 17:27 PDT
Investigating
We’re experiencing connection issues impacting some Cash App services. Customers may encounter delays when attempting to link a debit card, add money, send a payment, or withdraw. Please avoid retrying actions while we investigate the issue. Thank you for your patience in the meantime.
Posted Apr 30, 2025 - 16:28 PDT
This incident affected: Send & Receive Money, Add Cash, Cash Out, and In-App Alert.