Cash App

Intermittent Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved. To check the status of your payment, please view your transaction activity. If your payment is still pending, please pull down on the screen to refresh and send.

Thanks again for your patience as we worked to resolve this issue.
Posted Sep 15, 2020 - 14:40 PDT
Update
We're experiencing connection issues and are currently investigating. If your payment is pending, please do not re-attempt at this time.

We'll be back with an update soon - thank you for your patience.
Posted Sep 15, 2020 - 12:54 PDT
Investigating
We're experiencing connection issues and are currently investigating. Some customers may encounter pending payments and transfers, and delayed Boost and itemized receipt updates. If your payment is pending, please do not re-attempt at this time, it will be sent automatically.

We'll be back with an update soon - thank you for your patience.
Posted Sep 15, 2020 - 10:41 PDT
This incident affected: Send & Receive Money and Offers.