We've resolved the issue impacting Cash App Taxes. You can find support for general tax-related questions at taxeshelp.cash.app. Thanks for your patience.
Posted Oct 03, 2024 - 11:00 PDT
Update
We are aware of an issue currently affecting your ability to access Cash App Taxes and contact our support team. Rest assured, our team is working diligently to resolve the problem as quickly as possible. In the meantime, please check your app periodically, as we expect access to be restored soon. We appreciate your patience and understanding during this time.
Posted Oct 03, 2024 - 09:44 PDT
Identified
We are aware of an issue currently affecting your ability to access Cash App Taxes and contact our support team. Rest assured, our team is working diligently to resolve the problem as quickly as possible. In the meantime, please check your app periodically, as we expect access to be restored soon. We appreciate your patience and understanding during this time.
Posted Oct 03, 2024 - 09:00 PDT
This incident affected: In-App Alert and Cash App Taxes.