Cash App

Cash App Borrow Issues

Incident Report for Cash App

Resolved

We've resolved the issue impacting Borrow. Thanks for your patience while we worked through this.
Posted Oct 24, 2024 - 06:59 PDT

Investigating

We're aware of an issue impacting Borrow and are working on a fix. We appreciate your patience while we look into. Please check here for ongoing updates.
Posted Oct 21, 2024 - 11:10 PDT
This incident affected: Borrow and In-App Alert.