Cash App

Inaccurate Activity feed
Incident Report for Cash App
Resolved
The issue causing the inaccurate display of payments, Cash Ins/Cash Outs, and Cash Card transactions has been resolved. Thank you for your patience while we worked to fix this.
Posted May 05, 2022 - 07:10 PDT
Investigating
Our team is investigating reports of some customers' Activity tab not displaying payments, Cash Ins/Cash Outs, and Cash Card transactions that have been successfully completed. Please check back here for future updates.
Posted May 03, 2022 - 16:07 PDT
This incident affected: Settings and In-App Alert.