Cash App

Direct Deposit Delays
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 20:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2020 - 14:20 UTC
Update
We are continuing to investigate this issue.
Posted Jun 18, 2020 - 14:19 UTC
Investigating
Some customers may be experiencing delayed Direct Deposits - we are currently investigating.
Posted Jun 18, 2020 - 13:33 UTC
This incident affected: Direct Deposit.