Cash App

Investing Delays
Incident Report for Cash App
Resolved
The issue with delayed Cash App Investing orders has been resolved. New orders will be processed as expected and existing delayed orders are currently being processed. Thank you for your patience while we looked into this.
Posted Nov 25, 2024 - 09:01 PST
Investigating
We’re currently looking into an issue with Cash App Investing. Some orders might be delayed. Please check back here for updates.
Posted Nov 25, 2024 - 08:38 PST
This incident affected: Investing and In-App Alert.