We've resolved the issue impacting paper money deposits. You may re-attempt any failed transactions at this time. Thank you for your patience.
Posted Mar 10, 2025 - 11:34 PDT
Investigating
We have identified an issue impacting depositing paper money and are actively working on a resolution. We'll share another update soon, thanks for you patience in the meantime.
Posted Mar 10, 2025 - 11:27 PDT
This incident affected: In-App Alert and Deposit paper money.