Cash App
Connection Issues
Incident Report for
Cash App
Resolved
We've fixed the connection issues impacting some of our features. Thanks for your patience while we worked to resolve this.
Posted
Apr
10
,
2025
-
12:40
PDT
Investigating
We’re investigating reports of connection issues impacting multiple Cash App features, and are working to resolve this quickly.
Posted
Apr
10
,
2025
-
12:35
PDT
This incident affected: Cash App Card, Mobile Check Deposit, Log In, and Deposit paper money.
×
Subscribe to Incident
Subscribe to updates for
Connection Issues
via . You'll receive .