Cash App

Delayed Logins
Incident Report for Cash App
Resolved
We've resolved the issue affecting customers being able to login. Thanks you for your patience!
Posted Mar 26, 2024 - 06:20 PDT
Investigating
We're aware of an issue causing delays in customers receiving SMS messages when trying to log in. Thanks for your patience as we investigate this further.
Posted Mar 26, 2024 - 05:59 PDT
This incident affected: In-App Alert and Log In.