Cash App

Connection Issues
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 20:01 PDT
Identified
We’ve identified the root cause of the connection issues and are working quickly on a solution. Please do not retry your payment. We’ll be back with another update as new information becomes available.
Posted Sep 03, 2020 - 16:36 PDT
Update
We are continuing to investigate this issue.
Posted Sep 03, 2020 - 16:08 PDT
Update
We are continuing to investigate this issue.
Posted Sep 03, 2020 - 15:57 PDT
Investigating
We're experiencing connection issues and are investigating. We'll post another update when we have more information. If you've attempted to send or receive a payment, there's no need to retry.
Posted Sep 03, 2020 - 15:57 PDT
This incident affected: Send & Receive Money, Offers, Add Cash, Cash Out, Investing, Borrow, and Bitcoin.