Cash App

Cash App Card
Incident Report for Cash App
Resolved
We've resolved the issues impacting multiple Cash App Card features. Thanks for your patience while we worked through this.
Posted Jun 20, 2024 - 07:31 PDT
Monitoring
We’ve applied a fix for the issue with Cash App Cards. We'll provide a final update once we’ve confirmed that this issue is resolved.
Posted Jun 19, 2024 - 16:23 PDT
Investigating
We’re currently investigating reports of issues with Cash App Cards. We appreciate your patience while we look into this. Check back here for ongoing updates.
Posted Jun 19, 2024 - 14:51 PDT
This incident affected: Cash App Card and In-App Alert.