Cash App

Cash Card Issues
Incident Report for Cash App
Resolved
The issue preventing customers from activating or linking their Cash Card to Apple or Google Pay has been resolved. Feel free to try again at this time.
Posted 22 days ago. May 02, 2019 - 19:30 UTC
Monitoring
We have found a fix for the Cash Card issues, and they should be implemented soon. Thank you for bearing with us.
Posted 22 days ago. May 02, 2019 - 19:16 UTC
Investigating
We're aware of an issue causing some Cash Cards to fail when attempting to add them to Apple Pay or Google Pay, or trying to activate them. We're working on a fix, and the issue should be resolved shortly.
Posted 22 days ago. May 02, 2019 - 18:31 UTC
This incident affected: Cash Card.