We've resolved the issue that was affecting Afterpay and Cash App Pay transactions. You may now retry any failed attempts. Thanks for your patience while we worked to fix this.
Posted May 06, 2026 - 12:00 PDT
Investigating
We're currently investigating an issue with Virtual Card and button integrations for Afterpay and Cash App pay that are experiencing elevated declined rates. Our team is actively working on a fix. We'll provide updates as we learn more.
Posted May 06, 2026 - 11:24 PDT
This incident affected: Cash App Pay and In-App Alert.