Cash App

App Crashing
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted May 25, 2023 - 19:33 PDT
Update
Services have returned to normal
Posted May 25, 2023 - 19:30 PDT
Update
We are continuing to investigate this issue.
Posted May 25, 2023 - 18:39 PDT
Update
We are continuing to investigate this issue.
Posted May 25, 2023 - 18:32 PDT
Investigating
We are aware of the outage causing general app crashing. Our team is currently investigating and will post updates here as soon as possible.
Posted May 25, 2023 - 18:12 PDT
This incident affected: Send & Receive Money, Cash Card, Cash App Pay, Direct Deposit, Mobile Check Deposit, Offers, Add Cash, Cash Out, Investing, Borrow, Bitcoin, Settings, Support, In-App Alert, and Cash App Taxes.