Cash App
Cash App Investing Issues
Incident Report for
Cash App
Resolved
The issues with Cash App Investing have been resolved - thank you for your patience.
Posted
Oct
16
,
2024
-
07:23
PDT
Investigating
We’re currently looking into an issue with Cash App Investing where some customers can’t trade stock. Please check back here for updates.
Posted
Oct
16
,
2024
-
06:51
PDT
This incident affected: Investing and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
Cash App Investing Issues
via . You'll receive .